Page 1 of 1

mingw32 stuff

Posted: Wed Feb 23, 2011 01:04 am
by Corbin
Hey guys,

Has anyone here used or have experience with the cross-compiler mingw? I'm setting up an environment in Windows to cc but it seems that when I try to MAKE something, the cc= part of the makefile won't link back to the compiler that came with mingw32. Seems to spit an Error 127 out at me.

For instance, I'm trying to compile the libogg library to statically link to the project, but upon running the makefile.xming, it bombs with command not found, error 127. So, it seems to be it's not linking to the compiler. Also - yes, I've set the path names in the Win32 environment for mingw32.

I've tried researching this error but it seems most solutions are on Linux using a different program. I know Linux is free and all, but I'd rather have it set up in Win32 for convenience.

Just seeing if anyone here has an idea to what I'm doing wrong.

Re: mingw32 stuff

Posted: Wed Feb 23, 2011 01:44 am
by I Live...AGAIN
Not I, sorry.

But I'm glad to see you still hard at work.

Re: mingw32 stuff

Posted: Thu Feb 24, 2011 03:35 am
by Corbin
Figured it out! Basically, my compiler isn't the default i586-etc., it was just basic gcc, so CC=GCC, and it worked. Now I'm in business!

@Joe: Always!