mingw32 stuff

Want to get your hands Bloody?
User avatar
Corbin
Zealot
Posts: 158
Joined: Sat Aug 16, 2008 09:48 pm
Location: california
Contact:

mingw32 stuff

Postby Corbin » Wed Feb 23, 2011 01:04 am

Hey guys,

Has anyone here used or have experience with the cross-compiler mingw? I'm setting up an environment in Windows to cc but it seems that when I try to MAKE something, the cc= part of the makefile won't link back to the compiler that came with mingw32. Seems to spit an Error 127 out at me.

For instance, I'm trying to compile the libogg library to statically link to the project, but upon running the makefile.xming, it bombs with command not found, error 127. So, it seems to be it's not linking to the compiler. Also - yes, I've set the path names in the Win32 environment for mingw32.

I've tried researching this error but it seems most solutions are on Linux using a different program. I know Linux is free and all, but I'd rather have it set up in Win32 for convenience.

Just seeing if anyone here has an idea to what I'm doing wrong.
User avatar
I Live...AGAIN
Cabal member
Posts: 762
Joined: Fri Aug 13, 2004 05:33 am
Location: Detroit
Contact:

Re: mingw32 stuff

Postby I Live...AGAIN » Wed Feb 23, 2011 01:44 am

Not I, sorry.

But I'm glad to see you still hard at work.
User avatar
Corbin
Zealot
Posts: 158
Joined: Sat Aug 16, 2008 09:48 pm
Location: california
Contact:

Re: mingw32 stuff

Postby Corbin » Thu Feb 24, 2011 03:35 am

Figured it out! Basically, my compiler isn't the default i586-etc., it was just basic gcc, so CC=GCC, and it worked. Now I'm in business!

@Joe: Always!

Return to “Programming Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest